Default Need help, urgent

Hi, I have a D806 G2 and I have a big problem.
After an error modifying my build.prop I was left with a broken phone. It wouldn't boot to the os.
I was rooted and with TWRP so I restarded and tried to revert to the old build.prop (that's the only backup I had) and it didn't work.
I followed the tutorials to go back to stock (I had done it once before to update my phone while rooted, but that time the phone was working fine).
Well, to my surprise, given that I only had recovery or download mode, the process started but failed with an error.
Now, I don't have a System, meaning that my system folder is empty so I really don't have an os in the phone, and all procedures to flash a rom, fail.
I have tried flashtools and everyother tool but nothing, can't put a rom in the phone.
Now I'm kinda desperated because It is too expensive for me to loose the phone (things in Argentina are far too expensive) and when I put it in download mode it clearly says ROOTED so I will have a problem with guaranty.
Please, someone give me a hand!!
What you see here is...
The rambling verses of a bored man who decided he should have a signature but didn't know what
to sign so he just sat there at his computer writing whatever came to his mind and as a result...
...now you know you should have stopped reading a long time ago, don't you??

PS: a simple Thank You does wonderful things, so hit the damn button.