Phone [Q] S2 Problem HELP!!!

i recently installed miui v5 on my galaxy i9100 i tried it out and didint like it so i downloaded the ressurection kitkat 4.4 rom i tried to flash it (i was using cmw recovery version 6) which it came it while installing something like 'installation aborted (status 7)' so i thought okay ill flash miui back and get another rom, i flashed back the miui it installed all correctly but when i rebooted the phone it gets stuck on the samsung boot logo and i get nothing so i went back into cmw to see if i could found out whats happend, i tried to wipe/factory reset the phone through cmw and i get 'error mouting sd card.android secure.. so i went into mounts/storage and tried to wipe the sd card just by itself that didnt work i also like an idiot whiped my external storage (usb storage) that had the Roms/gapps in and now im stuck and cant do anything, there is no sideload on cmw.. so what can i do to flash a new rom and what rom can i use that will 100% work smoothly i want it to be 4.4