Default [Q] i337 - MF3 v4.2.2; unable to change ROM

I currently have the Samsung Galaxy S4 - MF3; v4.2.2; i337. I got the phone unlocked (direct from AT&T); and then

1. followed this method to root my phone - http://forum.xda-developers.com/show....php?t=2387577- Worked.
2. Got Safestrap v3.65 - http://blog.hash-of-codes.com/downloads/safestrap/ - Worked.
3. Tried 3-4 different ROMs, none of them have worked.
a. http://forum.xda-developers.com/show....php?t=2356276
b. http://forum.xda-developers.com/show....php?t=2418522
c. http://forum.xda-developers.com/show....php?t=2630085
d. http://forum.xda-developers.com/show....php?t=2537495
4. Tried above ROMs with kernels from here - http://forum.xda-developers.com/show....php?t=2292341 (v4.2.2 or v4.4 - depending on the ROM) and also the MF3 kernel (can't find the link)

But, irrespective of what I try, I still get stuck while loading the ROM - blank screen, not moving forward. Could you please shed some light on what I should try to do?

Thanks!