Default [Q] Google Play Store installation problem

I have a Samsung Galaxy Ace S5380i running on android 2.3.6. I have already rooted my mobile and transferred most of the applications on SD card to clear some internal space. I actually also deleted Google Play services, Google Play Books and Gmail as I am not using them. All other apps I re-installed such as Google Maps are OK apart from Google Play Store. It was initially showing No connection Retry.

I tried some methods posted on the website but nothing works. I tried clearing data and force-stopping the app, then reboot but after a while the app crashed when I tried downloading an application. I got this message: "The application Google Play Store (process com.android.vending) has stopped unexpectedly. Please try again"

I wiped also cache through the system reboot but I had the same problem but also sth strange happened, Google Play Books app re-appeared in my menu.


I tried also deleting hosts.txt from \system\etc folder and even editing it as suggested (There was only one line on my hosts.txt: 127.0.0.1 localhost):

127.0.0.1 localhost
#74.125.93.113 android.clients.google.com

but I had the same problem after a while.

I finally tried changing my Google account password and this helped only for a little bit as I got the same message. I get this message even when I am trying to download an app from the web version of Google play.

Can somebody help me please? Any ideas?