Or Continue to Thread: [Q] S3 Stuck on samsung logo a…
Find Your Device:
19th February 2014, 04:13 PM   |  #1  
OP Junior Member
Thanks Meter: 4
 
5 posts
Join Date:Joined: Feb 2014
I have an unrooted Samsung S3, i just received yesterday the notification of the jelly bean 4.3 update (originally ran on 4.1.2) so i went for it OTA via wifi, long story short, after download was finished and the phone automatically rebooted itself, it got stuck on samsung logo, i have waited for hours beside it (since i have modest experience about this) and finally nothing happened, so i started researching the issue, i have tried wipe data/factory resetting (didn't work) along with wipe cache partition, and no use, i have tried kies emergency firmware upgrade and initialization, but it can't see the phone in Download mode, i tried flashing the phone with Odin307 but it also cannot see my phone in Download mode, and i have heard that if the phones usb debugging was active, the phone would be seen, but i never used it, my phone was stock all the way, please help me get my phone working again.
The Following User Says Thank You to herculese911 For This Useful Post: [ View ]