Or Continue to Thread: [Q] Custom ROM: Stuck at Sony …
Find Your Device:
21st February 2014, 06:09 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
5 posts
Join Date:Joined: Feb 2014
I am new to Android mod. I was trying to install CyanogenMod for Sony LWW from here: http://download.cyanogenmod.com/?dev...ut&type=stable

I installed CWM Recovery, and took a backup that gave me: cache.yaffs2.img data.yaffs2.img nandroid.md5 system.yaffs2.img
I followed the following steps:

0. Downloaded the ROM and placed it on your SD Card.
1. Booted into CWM Recovery
2. Wiped Cache, Wiped Data and went to "Mounts and Storage", and formatted "/system". Also, went to "Advanced", and wiped "Davlik-Cache"
3. Went to Install zip from SD.
4. Selected the Downloaded ROM zip file.

The installer crashed at assertion:

Code:
assert(getprop("ro.product.device") == "WT19a" || getprop("ro.build.product") == "WT19a" || 
       getprop("ro.product.device") == "WT19i" || getprop("ro.build.product") == "WT19i" || 
       getprop("ro.product.device") == "coconut" || getprop("ro.build.product") == "coconut");
So, I had to reboot. When I rebooted... it was stuck at welcome screen.

I tried to go to CWM Recovery by holding volume-down key at boot. Nothing happened. Removed/replaced battery, tried again nothing happened.

So, I decided to follow "turning brick into smartphone" article here: http://forum.xda-developers.com/show....php?t=1568792
I installed FlashTool on Ubuntu 13.10 as described here: http://duopetalflower.blogspot.in/20...ntu-linux.html
But Flashtool does not detect the device.

Can someone guide me how to fix this?

---
Edit:

When I tried to start in flashmode. Replaced battery, held the volume down key, and inserted USB jack. FlashTool showed "device connected", but then a few seconds later. It shows device disconnected and the phone goes back to welcome screen.
Last edited by naishe; 21st February 2014 at 06:54 PM. Reason: added some more details