Default [Q] Help needed please. Stuck on boot screen.

Hi guys. I was hoping that maybe some of you genius's maybe be able to help me out? I will try and explain my problem as clearly as possible.

I have an I9305 and an from the UK. I have rooted my phone before and used many custom roms. But quite recently I decide to unroot my phone and go back to a normal stock rom. Last week I got the urge
to root again and install some custom roms. I quickly discovered that since I had OTA my phone that the latest OS has problems (knox) with rooting. I did manage to root my phone. However, the problem started when I tried to install
twrp through Goomanager. I tried to reboot into recovery mode and my phone was stuck on the Galaxy S III splash start screen, and I could not get into recovery mode either. I could still get into download mode. Eventually I did manage
to restore my phone using odin, and install a stock rom for Ireland. After this I tried to install a stock from for the UK, and now my phone is now back to being stuck on the splash screen, and I can not enter recover mode on my phone
using the up/home/power combo, but I can still acces download mode and conect to odin. I have been searching on line for several days for some solutions and fixes, but I seem to be getting no where. So please, if you can help my out and hopefully get my phone back to life I would
be extremely grateful.