Default [Q]Superuser Binary needs to be updated?

Guys I was trying to root my bro's GS3 with odin.. the flashing went perfect, infact there was a SuperSU and CWM app installed too, but when i tired to open the app it was showing that SU bianary needs to be updated..
I even updated the SuperSU from the Play store but was getting the same error essentially.. also tried the Superuser FIxer app from PS but it also stuck at
Gaining root access :fail
I tried flashing the SuperSU 1.51 .zip from the recovery mode by placing it in internal memory but to my surprise the file path of the internal memory was not visible and when i inserted a sdcard and copied the file to it and then tried to flash it thru recovery, it was successfull but got a few erros , something like who file not successful(will try again and post exact same thing in by tomorrow)
in the meanwhile can anybody help me? plz its urgent..

phone was on stock rom 4.3 OS before root
Nokia 6233 2008-2010 (still use it as secondary phone)
Nokia 5230 2010-2011 (worst mobile phone.. ever!)
Samsung Galaxy S I9000 2011- (Need a new cell.. Damn i gotta get good marks )
Oneplus One - COming soon