Default Galaxy S4 boot loader update XXUFNB9

Hi

I use to have a HTC one and use elegancia rom, now I have moved to a S4.

S4 is rooted and I have been using other roms with no issue, But there are now Rom's that require updating the boot-loader and GSM firmware.

This is my problem its driving me nuts now,

I would like to use the fowling rom http://forum.xda-developers.com/show....php?t=2253528 and need to update the boot-load and GSM firmware.

I open odin and click on CP with no auto reboot and flash with I9505XXUFNB8_GSM_LTE_Modems.tar.
I then reboot and do it again this time with an auto reboot, I found in a forum on XDA this is the best way to do it.
if I did a once flash it never upgraded.

When I look in Samsung info app it says baseband I9505XUFNB8 , looks to me if the flash work ?

Now I try and flash the boot loader with odin , selecting BL option with auto reboot with file BL_I9505XXUFNAD_481100_REV06_user_low_ship_MULTI_C ERT.tar.md5


looking in Samsung info this has all work, but my wifi will not work with rom that requires the firmware for gsm or the bootloader.

works fine on any other room that dont need these , very strange.

Hope some one can help.
Attached Thumbnails
Click image for larger version

Name:	samsung info.jpg
Views:	6471
Size:	136.2 KB
ID:	2624668