Or Continue to Thread: [Q] Network Lock on Galaxy S2 …
Find Your Device:
13th March 2014, 10:47 AM   |  #1  
OP Member
Thanks Meter: 2
 
37 posts
Join Date:Joined: Jun 2011
Hi folks,

I have a pickle of a situation here that I am finding it hard to grasp why this Network Lock continues to plague me.

Seems I cannot manage unlock a Galaxy S2 handset even with the correct IMEI.
Or to understand what exactly is going on here which brief story as follows.

The IMEI number is written on the back of the phone under the battery.
The code *#06# displays IMEI also displays the correct IMEI.

I then go to the Vodafone Site to unlock: https://unlock.vodafone.com.au/voila...=selectService

I enter in the correct IMEI number, after I enter the Captcha code and click next, it replies with the Unlock Code for me.

But every time I enter in the Unlock Code that I was given, it returns: Network Unlock request unsuccessful.


I then flash the phone with Odin to a official XSA version, still the same.
I then return to the Voda Rom and its still the same.

Yet, if I use a Voda sim on either Rom it works perfect.

For the life of me, how does one get past this Network sim lock?

Anybody got any ideas to why or how to solve this matter?