Default [Q] twrp flash from 2.6.3.2 to 2.7 error

I want to update to 2.7 but when i flash zip file the recovery say zip file corrupted. So my phone is corrupted or the file is corrupted?
Update : now it say error flashing zip .....
I reflash the 2.6.3.2 version and it still wok very good
Maybe the rom is affect the twrp? Mine is omnirom kitkat
I hope the team win read this.