Default [Q] Rooted but not sure how to upgrade from 2.3.5 to latest cynanogenmod

Hey Guys,

I just rooted my S2 and want to install: http://forum.xda-developers.com/gala...ghtly-t2604068 however it says that I "Must be at least once on stock ICS or JB before attempting!".

I don't know how I am supposd to upgrade my 2.3.5 so that this is possible...

Any advice?
if (Signature = TRUE) {
.. if (Device = "Google Nexus 4") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
.. if (Device = "Google Nexus 10") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
} else {
.. Retired Devices == HTC Desire Z, ASUS Eee Pad Transformer Prime, Microsoft Surface RT;
}
}