Or Continue to Thread: [Q] Hardware failure?
Find Your Device:
18th March 2014, 05:20 PM   |  #1  
OP Junior Member
Thanks Meter: 2
 
14 posts
Join Date:Joined: Feb 2011
Last night all the apps on my 16gb Nexus 4 crashed inexplicably at the same time. I tried rebooting and the phone just looped the loading animation endlessly. I tried going into recovery mode and doing a factory reset but get the following errors:

E:failed to mount /cache (Invalid argument)
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log

(It repeats these several times before giving up)

This morning I downloaded the Nexus Root Toolkit to try and reflash the stock software, but with no luck. The bootloader is still locked (I never had a need to root this phone... so I thought...) so it won't allow me to flash updates. When I try to unlock using NRT, I just end up in another boot loop.

I've also tried to sideload the stock image through the phone's recovery but get the same errors. If I try the "wipe cache partition" option I get the same errors (but change /log to /last_install) with 1 additional:

E:Failed closing /dev/block/platform/msm_sdcc.1/by-name/misc
(I/0 error)

So my question is, how hosed am I? What have I not done that I should try? Is there a way to flash or sideload just an unlocked bootloader? Any ideas about how to fix this unmountable E:? Or has my phone just exploded?

Thanks in advance for your help!!

Kevin