Or Continue to Thread: [Q] [HELP] Device is dead!
Find Your Device:
Exothermic
24th March 2014, 04:00 AM   |  #2  
Guest
Thanks Meter: 0
 
n/a posts
Quote:
Originally Posted by Renton91

Help me, please!
Hello guys, I really need an aid:
I was wiping my cache and dalvik-cache in recovery mode when the phone turned off. Since than it never turned on again and I can't access neither to bootload nor recovery, just black screen. I tried to change battery or charging it but it doens't. I even tried to plug it to the pc and it only plays the connection and disconnection notification chime in loop.
I don't know what else to do!!
Please, can someone help me??

Seems like a hard brick, um first wait until battery depletes and try charging, hopefully that works. If not, try getting your hand on a usb jig (or making your own) search for it, and if that doesn't work then you need to send it in for repairs, or find a service shop that offers JTAG service.
If you do send it in for repairs, act dumb and say you were updating via kies and that was that, most of the times, they change motherboards or just jtag it so they don't check too into it.
The Following User Says Thank You to For This Useful Post: [ View ]