Greetings,you should be able to Disable this Icon in your Phone Settings
Go to the General Tab and tap Accessibillity there Disable the Universal Touch Feature