Prompt Galaxy S2 Won't Boot, Stuck at Model Logo Screen

Hi everyone,

I found my non-rooted officially updated Ice Cream Sandwich Galaxy S2 phone turned off a few days ago. Upon switching on it won't go past the I9100 Samsung Galaxy S II screen, no matter how long I wait. I haven't flashed it before this moment with any custom ROMs or did actually make anything funny to it, including rooting.

Using Odin different versions I tried flashing it with official ROMs but it generally gets stuck either on NAND Write Start or at Set Partition/cache.img. Since only with the ROM with no pit, modem and CSC files I got no result, I was advised in another forum to flash with them so they can see what I reach. The suggested files were CODE_I9100XXLSJ for PDA, emmc_EXT4_16GB.pit for PIT, MODEM_I9100XXLS6 for Phone, and for CSC - CSC_HOME_OXX_I9100OXXLS1.

The second version which was a bit earlier was PDA CODE_I9100XXKG3_CL401405_REV02_user_low_ship.tar, u1_02_20110310_emmc_EXT4 PIT, MODEM_I9100XXKG3_REV_02_CL1040774.tar phone and GT-I9100-CSC-MULTI-OXAKG3.tar.

I tried flashing with both using almost every Odin version, from 1.3, 1.83, 1.85, 3.04 to 3.09 with only being able to reach the stages of NAND Write Start and Set Partition. I can only access download mode and not recovery mode.

Since I have been trying to solve the problem for a few days now, I also removed the battery for more than 2 minutes before flash, moved through different USB ports, going with different Odin versions, turning my anti-virus program off (I don't have KIES installed) with no success after the above point. The only thing I can't do now is change the USB cable but it is a nice one and the drivers and Windows recognise it OK with the phone. Since a xda thread I found suggested that re-partitioning off helped many people in my phone state I tried that too without opportunity to go any further. I also removed my SIM card and external 64 GB memory card just to check if there would be any difference (and also knowing this is recommended for wiping out their content), no help.

Can anyone give me advice what I could do to get the phone back to life? Could the internal 16GB memory be dying? Can I use something like the shared here http://forum.xda-developers.com/show....php?t=1823918 to check on bad sectors?

This is my first time to go through such experiences so excuse me if I have missed something. I will get back with more details as required. Thanks for your comments!