Remove All Ads from XDA
Find Your Device:
Or Continue to Thread: [Q] Bootloop after RUU attempt…
20th April 2014, 04:22 AM |#1  
OP Junior Member
Thanks Meter: 0
I recently tried to revert back from CM 10 to stock on my HTC one.

Everything seemed to be going fine, I found what I believed to be the right RUU(I couldnt find it in a .exe, only .zip) .
And I successfully used revone to get s-off, remove tampered and change unlocked to locked in the bootloader.

But when changing s-off back to s-on the security warning banner showed up in the bootloader and for some reason I couldnít get into the OS anymore, it just went straight to the bootloader. I didnít bother thinking about it since I was going to install the RUU either way. But I get the same error every time I try to install it: FAILED (remote: 12 signature verify fail). Also I couldnít get into recovery, it just shot be back straight into the bootloader.(Correct me if i'm wrong but did the fail because you have to have s-off for it to work? Would make sense.) On top of that I couldnít just get s-off again because for some reason i can only use adb commands when the phone is in the actual OS, it doesn't seem recognize it when its in bootloader/fastboot/recovery, fastboot commands work fine tho.

I was able to unlock the bootloader again using htcdev and I can now access twrp, but I can't seem to be able to factory reset, it just says: Unable to mount /data and unable to mount internal storage. The mount option in twrp does not seem to work either, trying to check data makes nothing happen. Also instead of it just launching to the bootloader directly on startup, it now gets stuck in a bootloop until you make it go into the bootloader.

As you can see i'm in quite the pickle and absolutely any help on either getting back to a functional CM or stock would be much appreciated.

The getvar all info:

(bootloader) version: 0.5
(bootloader) version-bootloader: 1.44.0000
(bootloader) version-baseband: 4A.14.3250.13
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 1.29.401.16
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: FA366W903347
(bootloader) meid: 00000000000000
(bootloader) product: m7_ul
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0710000
(bootloader) cidnum: HTC__Y13
(bootloader) battery-status: good
(bootloader) battery-voltage: 4065mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
getvar:all FAILED (status read failed (Too many links))
finished. total time: 0.045s

If any more info is needed just ask