Or Continue to Thread: [Q] having issues with 2 new d…
Find Your Device:
30th April 2014, 05:45 AM   |  #1  
OP Member
Thanks Meter: 28
 
37 posts
Join Date:Joined: Oct 2009
I'm having big issues with two new Droid Maxx phones. Consumer edition with BL unlock. These shipped with Android 4.4, and I unlocked the bootloader fine. Loaded TWRP 2.7 fine.

On the first phone, I had a problem immediately when trying to downgrade to 4.2.2. Per the guides I downloaded the 4.2.2 files and used mfastboot to push all but the gpt and motoboot files. fastboot flash system system.img failed at the very end with a strange error 'sp error space is not enough'
What I tried to do to fix: A) I went back through, trying to push the 4.4 files, and I find it gives that same sp error regardless of the version file. B) I tried pushing boot.img as system and it did save.

When I do the exact same steps on phone #2, they complete fine.

I suspect this is a partition/sizing issue, but flashing the gpt from 4.4 and rebooting does not fix the sp error. Can someone on this forum help me diagnose this further? Perhaps getting a partition output from phone and comparing it to the output from phone 2? I would need commands to type this in using fastboot, twrp, etc.

-

The second issue is that although TWRP 2.7 works fine,
with either phone 1 or 2, if I perform a backup of system/user/boot, and immediately do a restore of the backup it just made, the phone starts doing continuous boot loops. (?). If I restore JUST the system then it will boot correctly.

I also tried using phone #1 by restoring a backup file saved from phone #2. it gives an error after restoring boot saying restore failed for image/system. any ideas?


THANK YOU!!
Last edited by traccdma; 30th April 2014 at 06:08 AM.