Question [Q] [Help] Stuck on Clockwork Mod 4.0.0.2 [Wiped everything off?]

Hey XDA,

I'm a complete noobie when it comes to rooting/unrooting and all that.
My phone (Galaxy S2) was on Android 2.3.5 and it was acting slow and draining my battery.

I tried to fix it but after everything I was getting frustrated and tried to update it to the latest version.
Samsung Kies did not recognise my S2, but it did recognise my girlfriend's S3.

My problem started when I tried to put the SimpleUpgradeTool that Samsung provided onto my phone, everything worked, but during the installation, it said 'Error occured'. The phone died and now I'm stuck with a phone which doesn't turn on (Stuck on Samsung S2 screen with Yellow Exclamation Mark) and if I press Volume + Power + Home Button, it starts up the Clockwork Mod 4.0.0.2)

My phone isn't recognized by Odin or Kies now. =/

My question is; is my phone fixable? As far as I'm aware, the only thing on my phone at the moment is the Clockwork Mod.
I can't access anything else.

If any of you could help, that'd be very helpful. I've got something in 2 days and it'd be amazing if I could use my phone before then.