Or Continue to Thread: WiFi Hotspot Error
Find Your Device:
9th June 2014, 03:05 AM   |  #2  
Senior Member
Flag Orange County, CA
Thanks Meter: 159
 
511 posts
Join Date:Joined: Aug 2013
More
Quote:
Originally Posted by GTI6speed

So I'm sure many of you are aware of this issue. I've encountered it twice on my Nexus 5 on both 4.4.2 and 4.4.3. Basically, if you enable/disable WiFi and WiFi Hotspot in a certain order, it breaks the tethering option and says error where it should say turning hotspot on after you click the box. Now, the only way I've been able to fix it is by doing a clean install of the factory images. Even writing the factory system, boot etc. does not fix it. Has anybody encountered this issue and found a way to fix it without wiping your phone?

I ran into this same exact problem on my N5 after I flashed the bootloader, radio, system and boot from the 4.4.3 factory image. It would say "error" under the WiFi Hotspot option when trying to activate it, even though it was working perfectly fine on 4.4.2. It was driving me crazy trying to figure out what it was happening. I'm not aware of any fixes. I ended up just backing up my stuff and flashing the whole factory image (including userdata.img). Then I edited the database file just like I did in 4.4.2, and now it works perfectly once again. It was all kind of a pain though.

Sent from my Nexus 5 using XDA Free mobile app