Default [Q] GTi9300 - Can't mount /cache/recovery

Hello,

I had a GT-i9300 running custom ROM temasek V95. Today morning suddenly the display went off and I couldn't access my phone. On trying to restart the phone got stuck on the samsung screen and hasn't gone past it. I have clockworkMod recovery v.6.0.4.6 installed on my phone and when I open it it says the following:

E: Can't mount /cache/recovery/command
E: Can't mount /cache/recovery/log
E: Can't open /cache/recovery/log
E: Can't mount /cache/recovery/last_log
E: Can't open /cache/recovery/last_log
E: Can't mount /cache/recovery/last_install
E: Can't open /cache/recovery/last_install

So, basically I can't do anything in the recovery. I have tried flashing with the SD card being out and in but has made no difference. I can get into download mode and have tried both Odin and heimdall but none of them work.

When I tried Odin and tried to flash stock ROM it just fails and says the following:

<ID:0/004> Added!!
<ID:0/004> Odin v.3 engine (ID:4)..
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> SingleDownload.
<ID:0/004> recovery.img
<ID:0/004> NAND Write Start!!
<ID:0/004> FAIL!
<ID:0/004>
<ID:0/004> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

When I tried Heimdall and tried to flash stock ROM, it says "failed to confirm end of file transfer sequence" every time and I never get a blue progress bar showing that it is transferring. I have tried almost everything but the fact that I can get into download mode suggests me that there's still hope.

Looking at all the help I could find online, I believe the problem is with the recovery and not the actual ROM. I have tried flashing a different recovery but that hasn't made any difference either

Can anyone suggest me a way out of this? This is really frustrating and I would like to know if the phone is definitely bricked or not Looking forward to your suggestions.

Please need HELP!