Or Continue to Thread: [Q] Can't ADD a Google account…
Find Your Device:
12th June 2014, 07:49 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jun 2014
Hello
Newbie at using Android here;
I have Galaxy S3 I9300, that was working fine until i rooted it and did bad manip with Titanium Backup !
It started to mess up, so i looked everywhere to fix it , tried everything and even finally unrooted phone; no joy.
Then i read; "Factory reset your phone" (which is Not the best solution), that i did ..; no joy there again !!

Phone won't go into Playstore due to the fact ; i cannot ADD on phone My Google account due to ( "Can't establish a reliable connection.."), also i tried to add New Google account; then phone says " name already taken, even if i typed ; "gbytjbgsdjjnen@gmail.com " !!

I then; Wiped data, Cache, partition etc ; No joy there either ..??

I'm pretty sure that it is nothing much to do ..but i do not know what it is ..
from what i read it can be a common problem but solutions varies
Does anyone having done all i've done found The Solution ..?
Thanks