Or Continue to Thread: A bricked Z1 with an unlocked …
Find Your Device:
2nd July 2014, 09:48 PM   |  #2  
gregbradley's Avatar
Forum Moderator
Flag Manchester
Thanks Meter: 4,435
 
9,896 posts
Join Date:Joined: Mar 2011
Donate to Me
More
Quote:
Originally Posted by Abu-7abash

So I got my Z1 yesterday, was on 4.4.2 stock unrooted. I unlocked the bootloader using Sony's official website and fastboot, then I went on destroying the phone by flashing Philz touch recovery.img through fastboot.

And since then the phone has been bricked, I can only enter Fastboot through the blue led, while Flash mode doesn't show up any LED light and my PC sees the phone when on flashmode as n "S1 device with a parameter error".

I've tried all drivers, none worked, and the flashtool keeps suggesting I should update my drivers when connecting the phone on flash mode:



Is there any way I can recover from this through fastboot instead of the flashtool? I can still flash system.img and recovery.img through fastboot. I'd really appreciate any help right now.

Xperia phones do not have a recovery partition to flash recovery to via fastboot.

If you can enter fastboot, then flash a stock kernel.elf with flashtool (In fastboot mode).

Then you can use flashtool to relock your boot (I imagine you have not even taken a TA backup and you are new to xperia devices, your post suggests so)

then you should be able to use pccompanion to repair, or flashtool to flash a FTF

However, by flashing a recovery image you may have bricked the phone. try what I have said, if it does not work get back in touch. (Do you have access to jtag and setool?)
The Following User Says Thank You to gregbradley For This Useful Post: [ View ]