Default [Q] Soft-bricked my Galaxy S3 i747. PLEASE HELP! I'm out of ideas

I tried rooting (my first time) and loading a gummy rom onto my s3 a couple days ago and ended up soft-bricking my phone and nothing I'm trying is bringing it back. Here's what I did:

- I rooted the phone and installed CWM 5.5. From there I made a backup of my phone and copied Gummy-M2.2-06-19-14-NIGHTLY-d2lte.zip and GApps_Standard_4.4.4_signed.zip onto my phone. I tried erasing the caches, installing the gummy rom from zip using CWM and it failed with a status 7. When I tried rebooting the phone it gets to the AT&T logo and freezes there everytime and even after everything I've tried, it is still stuck there.

Here are the things I tried to fix it:

- First thing I did was factory reset, erase the cache, dalvik cache, and tried to restore. Still stuck at the logo.
- Then I tried factory resetting it, erasing the caches and rebooting. No go.
- I tried modifying the updater-script file in the gummy rom to remove the check for my device but I still got an error when I tried loading it in CWM.
- I tried downloading a stock AT&T rom and flashing with Odin 1.8.5 and 3.09 but odin always gives me this:

<ID:0/004> Firmware update start..
<ID:0/004> SingleDownload.
<ID:0/004> aboot.mbn
<ID:0/004> NAND Write Start!!
<ID:0/004> FAIL! (Auth)
<ID:0/004>
<ID:0/004> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

My phone in download mode gives the following error after I try flashing:

SW REV CHECK FAIL : Fused 2 > Binary 0

The stock ROM I tried is I747UCDLK3_I747ATTDLK3_ATT. I've downloaded multiple copies of this and tried them all to no avail.

I'm starting to read about boot chains, bootloaders, and PIT files but I'm very reluctant to try any of that bc from what I can tell it can be very risky. Please help, I'm at a loss now and running out of ideas.