Default [Q] T-Mobile Note II is only partially rooted.

Hi All,
Recently I tried to root my T-Mobile Note II running stock 4.3 with a few of the one ctick root apps. I've tried framaroot (no go), towelroot (not supported) rootmaster (vRoot) I think that's where the partial root came into play. It installed an app called kinguser (that says I'm not rooted WTH!). It also installed it as a system app, so now I can't uninstall it. I installed supersu which has to update binaries, but it won't disable Knox. Rootchecker also says I'm rooted somewhat. The 1st paragraph under congratulations says I'm rooted. Everything else says no I'm not. User and group ID is not returning or something to that effect. When I learned about the one click apps I thought it was a Godsend because I don't have a computer. I've tried so many things to try to get around Knox, nothing is working. Installed it then deleted it like I read somewhere, tried the su pm com.sec.knox.seandroid on terminal emulator still no go. I even tried to play around with the commands for knox on terminal emulator atill no go. I don't know if its something security related with the phone or what. I used towelroot on my girlfriends Sgh t999L with stock 4.3 and it worked. So now I'm really pissed! I've searched the web for anything like this and couldn't find nothing. I know I'm not the only one this has happened to. I used some app cant remember the name, but it did ask me to use root access for something. But it wasn't through supersu. Plus it wasn't a root type of app so I refused access. I'm trying remember everything before I post this, dont wanna post it and remember something right after I do. I know its a lot of great minds on hear hopefully someone will be able to help me out with this situation. Thanks in advance XDA members..

PS. Does anyone know what modstring. I can use to maybe get towelroot to work? Or of any other terminal emulator commands for knox.