Default [Q] A real brick? Can not mount system

Hello all -
I have been toying with this gen 1 (maybe 2... not sure) off and on for about half a year now.

The device used to work great and was running stock OS. One day it just gave up the ghost. My daughter was using it and it would not start up into the OS. When starting the device, it would load the yellow Kindle Fire screen and just hang indefinitely.

Using a factory USB cable, I was able to use KFU and get TWRP loaded.
Within TWRP I can see the SD card (contains ".android" and "TWRP" folders) and even load files from the PC to the SD card.
When I go up levels, I can see what I think to be the OS directories, but none of them seem to contain any files.
One of the folders is named 'system' so I have a good feeling this is the OS.

However, I am not able to mount the system nor the data partitions within TWRP.

On my PC I can explore the device and I can see the SDcard perfectly fine, but no system or data.


What I would like to do is just reload the stock OS back on.
I have loaded the latest Amazon update to the SD card and tried to install it.
Near instantly, the TWRP screen says that it can't find directories and it fails/stops.


I have tried every button in TWRP for fixing permissions, wiped system, cache, etc. (everything cleared), resetting everything etc etc.
To no avail, I still can't get the system to mount.
I do encounter an error when fixing permissions as it fails every time. It says it can't fix permissions and wants me to try again after booting a ROM. (whatever that means?).
.
I have also tried using adb shell to force the device to reboot into fastload and then load the OS update.
I was able to get the latest TWRP loaded this way, but could not get the OS to go.... again, it can't find the directories.


Currently, when I start up the device I get a blue logo screen and can get into TWRP. If I go to boot normally, it continues to the stock yellow logo, dims, and freezes.