Watch This Now!

Find Your Device:
Or Continue to Thread: [Q] Corrupt bootloader and bla…
9th July 2014, 11:36 PM |#1  
OP Junior Member
Thanks Meter: 0
Hi there

@bftb0 : yet another victim of the corrupt bootloader .img ! (see thread #2573015)
Originally Posted by bftb0

The versions distributed with JWR66Y and KOT49H* Google factory images are INVALID.

Device : Nexus 7 2012 wifi (grouper), stock 4.4.4 KTU84P, never rooted before

Symptoms : black screen, not booting at all even to bootloader.
Only faint light of hope is that my PC is still reacting to plugging the Nexus in with USB.
Windows beeps and shows an "unknown usb device" error then fails finding a driver.
Windows Device manager shows "APX" with yellow sign below "Other devices".

Question : bricked or any hope left ? Pleeease what can I do ?

How I got there :
NRT hung when flashing bootloader while reinstalling stock 4.4.0 (nakasi-krt16s-factory-da7dee49).

The story, going from bad to worse :
It started with a sudden reboot for not appearent reason (incidentally while an Avast routine scan was running).
Then endless reboot, with the 4 color balls shaking indefinitely (power plugged in or not).

Looked at forums... Reboot into bootloader. Recovery mode, wiped cache. Got plenty of error msg "E:failed to mount /cache"

Bootloop! Sometimes showing just the white Google logo, sometimes showing the rolling colors for a few seconds.
Recovery mode, erase user data (no backup, hate this thing). Again plenty of error msg "E:failed to mount /cache"

Could the missing /cache be related to Avast since the first reboot occurred while it was running? Maybe the theft protection is overly proctective?

Installed Nexus Root Toolkit 1.8.4 (extremely well done utility btw, ***huge congrats*** ) on Win 7 64bits. Installed drivers #1.

Tried flashing a clean 4.4.4 (nakasi-ktu84p-factory-76acdbe9).
FAILED (remote: Bootloader is locked.)

Successfully unlocked bootloader with NRT. Restart with an open lock below the white Google logo. So far so good.
Try flashing 4.4.4 again, same image.
writing 'bootloader'... FAILED (remote: (InvalidState))
What the heck ?!

Found the thread #2573015 I was quoting above on corrupt bootloader .img files from Google.
As it turns out, the bootloader MD5 is also WRONG in KTU84P.

Managed somehow to restart into bootloader again in spite of the bad bootloader...
Maybe the old one was not completely replaced yet?
Quick quick, let's try flashing another bootloader that works !
This time use the latest available with a non-corrupt bootloader .img : 4.4.0 (nakasi-krt16s-factory-da7dee49)
erasing 'boot'... blahblah
sending 'bootloader' (2100 KB)... OKAY [ 0.281s]
writing 'bootloader'... *** STUCK ***
Wait and wait until lost hope

Tried rebooting but nothing happens, just black screen, I end up with the symptoms I described upfront.
When plugged into the pc, keeping power button down makes windows beep, and the "APX" unknown device comes and goes in win device manager. Adding the vol+ or vol- buttons (or both) produces identical results.
Uninstalled APX device from PC. Power button down. Windows beeps "unknown usb device". "APX" shows up again in device manager... And so on.
Screen still pitch black.

Any other USB driver I can try to regain a working connection?
Worth looking into other remedies, like nkFlash?
Originally Posted by GedBlake

If you corrupt, or erase the bootloader... the Nexus 7 is dead, from which there is known recovery. Although it's been speculated that an nvFlash tool could flash a new bootloader.

Thanks for reading me so far, I know it's long, but if you've read to this point maybe you can help?
Last edited by capslock0; 9th July 2014 at 11:51 PM.