Default [Q] backup fails to restore twrp and cwm

hey peeps,

got a slight problem with restoring my stock backup...

I installed twrp-2.7.1.0 after rooting with ioroot. Then backed up my rom. did a factory reset then realised there is an issue with installing on this version of twrp. so i then restored, installed flashify and installed philz touch cwm v6.48.4. loaded in to this recovery performed another back-up then tested a couple of roms (slimkat 4.4.2 & cm11 nightly).

i then needed to restore my rooted stock backup within cwm so did a wipe for new rom and tried restoring the back up.
Got an error on the md5 check, disabled the md5 check and retried and the install failed on the cache! i also tried doing a custom restore leaving out the cache but it just caused a boot freeze on lg.

I have now re-installed cm -> flashify and flashed twrp version used previously to back up, loaded this and tried restoring the back up from twrp and it has pretty much the same effect!

I also forgot that this version of twrp cannot install c-roms so now am stuck on twrp!

oh and i have also tried this threads recommendation which previously worked:

"What worked for me was from the TWRP terminal command was to type
dd if=/dev/zero of=/dev/block/platform/msm_sdcc.1/by-name/fota
then hit enter
type
dd if=/dev/zero of=/dev/block/platform/msm_sdcc.1/by-name/misc
then hit enter and reboot."

have tried searching for problems with md5 and how to change the md5 back to match the back-up to no avail...

any help would be great please?

Edit: Annnnd now ive installed the v510 twrp on my v500!!!