Or Continue to Thread: Can't charge with OEM Adaptor,…
Find Your Device:
12th July 2014, 02:38 AM   |  #1  
crazy_dr0id's Avatar
OP Senior Member
Thanks Meter: 24
 
108 posts
Join Date:Joined: Nov 2012
More
I'm having a charging issue and am lost on what else to try to fix this. I can't charge using my OEM adaptor and cable, only when connected to PC with USB. The USB cable that works with my PC is the same one I use with the adaptor.

The USB port is on my phone is good, charges fine when connected to PC (although much slower because of different mVS). Read a suggestion to make sure the tab part of the USB connector isn't bent, it doesn't look damaged at all and like I said, has zero problems connecting to my laptop.

Have tried almost everything except going back to stock, and nothing fixes it. I've turned debugging mode off and back on, restored a backup from before the issue began, completely wiped and reinstalled 2 different build of ROMs with and without apps, fixed permissions, tried different kernels, different USB cables...

The adaptor is in good condition. But when plugged in while my phone is on, it doesn't recognize that's it's connected. Previously it would give a false charging reading. If my device is off, sometimes I would get the grey bar battery, but now it's just vibrating every few seconds. Idk what to do...