Or Continue to Thread: Weird One S - S3/S4?
Find Your Device:
15th July 2014, 04:48 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jul 2014
Hello and greetings from Poland!

Guys, please, help - I'm a new happy owner of HTC One S, which i received from China/Singapore (heaven knows) just today.

I bought Z520e (S4) version, naturally. Telephone was bought as "brand new", but I know it may probably be refubrished (mini scratches on camera border, copy-like instruction) - I have no problem with that.

But...
Telephone is fantastic, to begin with. Anyway, I spotted the 3G/HSDPA problem (it only works on EDGE). During internet lecture, it became very hot (even warmer than my Xperia U under stress), and I thought "holy cow, and what if I received S3 one?". When I opened the upper part (where microSIM card is), i spotted small, black sticker. It said "Z560e".
"Oh noes", I thought - I called the seller and said I want a refund (Z560e not Z520e, USB cable not working <"Unknown device" error>, 3G/HSDPA not working). He said it is not a problem.

But...
I used non-OEM USB cable, and Windows normally identified device, installed the drivers, and telephone started working as mass storage. I installed benchamrks and device info apps: Quadrant, Antutu, CPU -Z. And this is the moment when things get interesting.
Results from those programs (sorry, I'm in work, and unable to post screenshots, so i will write down the most interesting parts):

CPU-Z:
CPU Architecture: Krait
Process: 28nm
GPU Renderer: Adreno 225

Those are S4 internals oO

Antutu:
Brand: htc_europe
Why phone from China/Singapore, having problems with European (Poland) 3G/HSDPA is marked as "htc_europe"? oO

Quadrant:
Product: ville
It says "ville", not "villec2" or something - so is it Z520e? oO

CPU:
Name: ARMv7 Processor rev 0 (v7l)
Max speed.: 1512Mhz
BogoMIPS: 13,53


Quadrant full test result: 4993.
Result is benchmark is much closer to S4 than S3 (more than 1000 from S3)...

Guys, please, tell me my phone is in fact S4, not S3...?