Figured it out, just had to turn the Navigation Bar master switch to ON in Gravity Box, but leave the "Enable Navigation Bar" check box unchecked. No navigation bar even after a reboot.