Exclamation [Q] Completely lost my device? (After flashing some ROMs)

Hello fellow people...
So, my lovely Android (LG P700) is stuck in a bootloop. So, here's the story of my phone:
1) I bought it and eventually managed to root it.
2) The same day I installed CyanogenMod 10. Everything worked so fine.
3) Later I upgraded to KitKat prime (Based on CM11). Pretty darn fine, but it was laggy like hell.
4) So I decided to downgrade back to CM10. It worked, BUT THEN - it ignored my SIM card completely and when dialed *#06# I found that my IMEI got torn off my phone.
5) So I installed AOKP KitKat. Was REALLY good but it didn't have some crucial-to-me options, so I found somewhat tasty...
6) And I installed the Pac-Man ROM. And something went quite wrong, because it only booted every third time, else it gave black screen, but everything worked really fine. But later, I noticed that Wi-Fi won't turn on, so guess what...
7) AND WHAM! MY WORST MISTAKE! Wait for it... I decided to install the Phenom kernel (Idiot me, it was made for CM10...), TADAA!
8) After the LG icon it gave me 3 random stripes distorted and pink in color. And the recovery is nothing but black screen.
9) So I tried to flash rooted v20d kdz to it... Nope. Only stuck on stock boot animation and the three button combo won't work, no recovery, no black screen, no data wipe option.
10) I used the official KDZ updater... Same sh* as 9).
11) Tried flashing rooted v10k... NOPE, the flasher is throwing the error: WParam: 4, IPARAM:1002.
NOTICE - Yes, I did data/cache/dalvik/system wipes everytime when I upgraded my ROM/changed kernels. I also used GApps every time.

Anyone can help me?
Thanks in advance!