Remove All Ads from XDA
Find Your Device:
Or Continue to Thread: [Q] Moto G 4.4.4 update breaks…
16th August 2014, 11:25 AM |#1  
OP Senior Member
Thanks Meter: 115
I tried to install the GPE rom on my bootloader locked verizon moto g this caused the device to show invalid system image at startup, after many failed attempts I was able to restore by upgrading to android 4.4.4 through Motorola device manger.
Now when I open Google Play it says "no connection, retry"
When I launch hangouts it says "Couldn't sign in because we couldn't reach Google. Try again."
If I try to enable Google Now "Google now requires location services which are not available" (location is on high accuracy)
I think the problem could be due to the fact that I bought and used the moto g in the US but now I am in Russia.
I tried most of the usual fixes for Google play services, none work and tried factory restore (I can't do the ones that require root, no root for 4.4.4)
Does anyone know a possible solution including downgrading?