Find Your Device:
Or Continue to Thread: i9500 can't install recovery (…
18th August 2014, 09:44 PM |#1  
OP Member
Thanks Meter: 1
Hi everyone. I was using my phone with stock rom for a while ans I wanted to pass to Miui cuz I heard 4.4.2 will be released soon.

I downloaded TWRP and tried to flash as I did everytime before with Odin. I flashed it and it rebooted, odin showed Pass with no errors, but when I tried to launch the recovery, it is still stock. I don't know what I'm doing wrong. I flashed it like this before and they always worked but this is not working. Is there another way to install this? I don't have root access but it wasn't an issue before. I have the usb drivers installed and debugging on. It was tricky to install drivers on Win 8.1 but it seems like installed correctly as it didn't showed an error.

Waiting for an answer please. I hate this exynos phone but my parents just not allowing me to sell this.
Last edited by LittleHedgehog; 19th August 2014 at 04:28 PM. Reason: FIXED!