Or Continue to Thread: [Q] HELP! Camera Error on all …
Find Your Device:
20th August 2014, 01:08 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
14 posts
Join Date:Joined: Apr 2007
Hi guys, I'm freaking out!

I'm proposing to my girlfriend this weekend and the PacMan ROM I was using (4.4.2 I believe) was lagging/running out of storage, so I decided to flash to the newest 4.4.4 ROM I could find. I wanted to make sure my phone was in tip top shape for the big weekend. I booted into TWRP and took the normal steps to flash (wipe ROM,dalvik,cache) but this time I also decided to delete internal storage because I was running out previously and just kind of wanted a fresh start. I decided to try the MerkMod ROM (4.4.4) w/PA 4.4.4 micro GApps, and everything worked great (fast, no reboots) after flashing....until I tried the camera maybe a day later. I got the 'Can't connect to Camera' error, and freaked out immediately because I need to snap some selfies of the big moment this weekend! I then tried deleting the camera thru Titanium Backup and flashing PA's Google Camera module, which didn't work either.

So then I went through all of the steps to go to ND8 stock from MerkMod as outlined by CNexus in this thread. I also switched to Philz recovery. Unfortunately, the camera would also freeze up/not start on the stock ND8 ROM as well (no explicit 'cant connect to camera error' but the screen was all black and the phone froze up). TW + samsung bloat was literally about to make me throw up, so then I decided to try SlimKat 4.4.4 w/Slim GApps, and I'm still getting the camera error. I deleted the Camera2.apk in SlimSettings and downloaded Google Camera, and that didn't work either.

I have no idea what happened! I don't think there was any physical/water damage to the phone, so I don't think it's a hardware issue. Should I try to go back to an older version of the stock ROM? Did this happen because I deleted my internal storage, or used PA Gapps (I've read that both might have contributed)? If so, how do I fix this!? PLEASE HELP!