Question [Q] Loosing mobile connection & GPS

I have developed an issue where a (seemingly random amount of time, can be over 24 hours, can be less than 12) after I boot my phone, I loose my mobile connection and GPS. I still have my WiFi. I have no way of knowing that this has happened until I look at the phone. This has been going on for a couple months now and is driving me insane. I have tried everything I can think of to fix it and I have posted in the Sprint specific Galaxy S4 forum, but I have yet to find an answer. I am hoping that posting to a wider audience may find some cure for my problem. I will post some very specific details about my phone, but any suggestions are welcome, even if the specifics are not familiar to you.

I have a Sprint Samsung Galaxy S4 (non-Spark, SPH-L720), rooted stock TouchWiz rom, Android 4.4.2 NAE (with MF9 bootloader, so no Knox), KT-SGS4 7/12/14 kernel, Philz Touch 6.48.4 recovery, SuperSU v2.01.

The following are frozen or deleted on my system (not listing items I consider irrelevant):
AllShare
CloudAgent
ELM Agent
Face Unlock
Knox (everything related)
Samsung Hub Updater
Samsung Link
Samsung Push Service
Security Policy Update
Sprint ID
Sprint Installer
Sprint Worldwide
TalkBack


My problem started after upgrading from system MF9 to NAE. For a while, NAE was the most stable operating system I had ever had on a phone. Then at an unknown point in time after upgrading, I began loosing my mobile connection and GPS a while after booting the phone. If I reboot the phone, I will immediately get the mobile connection and GPS back, until I loose it again and I always do.

I will point out that I recently discovered the app No Signal Alert and installed it, thinking that at least I would know when I loose my mobile connection. However, No Signal Alert does not detect a loss of signal when I loose my mobile connection, and still shows a good signal strength... this certainly confuses me.

Because system NAE was working perfectly for a while, I tend to think the problem does not specifically lie with the upgrade, something had to have changed in my phone to have caused the issue, as I see it.

I had messed with the APNs on my phone in an attempt to get MMS working, and in the process, through a misunderstanding of the app APN Backup & Restore, I had ended up with a massive APN file. I got this fixed, but it did not correct the issue. Also did a ##72786# reset. All during this time, I was also unable to update my PRL or Profile, as I would get an error. Eventually, for some reason, I got my PRL and Profile updated, but that did not fix my issue. I even Nandroided back to before I had messed with the APNs, still no luck.

Based on things I read, or on my on intuition, I tried going back to a prior kernel version, no help. I removed the ViPER4Android sound mod, no help. I use XPrivacy, but I monitor the restrictions closely and nothing is occurring there that should cause an issue. I seem to have battery overcharging issues with my phone and I have read a post by one user relating battery issues to connection issues, but since restarting my phone solves the issue, I don't see this being related.

I have attached a LogCat recording using CatLog (set to Warn or higher) of an attempt to place a call while my mobile connection was lost... I am personally unable to tell if this shows anything useful or not.

What is so frustrating to me about this is WHY does the mobile connection and GPS work perfectly fine for a while after booting, then stop? Obviously, something is occurring and I don't know how to find out what it is...

So... ANY ideas, wild conjectures or knowledgeable help would be GREATLY appreciated!
Attached Files
File Type: txt no_mobile_connection.txt - [Click for QR Code] (51.0 KB, 6 views)
*** Sprint Samsung Galaxy S4, Stock rooted Touchwiz rom, Android 4.4.2 NAE (MF9 bootloader, no Knox), SuperSU V2.01, Busybox v1.20.2-cm9, KT-SGS4 4.4 kernel, PhilZ Touch 6.48.4 recovery ***

Leave me alone, I know what I'm doing!

(except when I'm totally lost...)