Unhappy [Q] Alright.. Help me root my NC4 note 3..

I've got a Verizon Note 3 now with the NC4 ota on it already. I need root. Not want need. I use my hotspot religiously. Tried towel root. Busy box wont install because of superuser permissions. I uninstalled all of them etc.. Nothing.. Factory reset my phone. Towelroot'd again. Then busybox. same message. "there was a problem opening a shell with root access. This is either being caused by a superuser/supersu or by a device that is inproperly rooted. Try removing superuser permissions, uninstalling this app reinstalling this app then regranting permissions. Well After rooting a factory reseted nc4 with towel root busybox showed this. So then i proceded to supersu. Tries to install shows option to disable knox fails. Installed superuser and tried to update binary, failed and crashed superuser.

Ever phone i've had has been rooted. thunderbolt/s3/n2/s4.. the note 3 has became the b*tch of the family that doesnt want to listen. Please help. I feel these threads overpopulate the forums but i've tried multiple times. given up waited a few months and tried again. This being my fourth attempt owning the phone im to the point where i want to give up and get my old s4 back.. So please help me with any information you can give.

Thanks

edit: yeah signature is old.. havent been on in a while sorry.
My list of phones:

Old Blue Samsung Flip Phone>LG Chocolate 2>LG Voyager>BlackBerry Bold>HTC ThunderBolt 4G LTE>Galaxy S3>Galaxy Note 2>Galaxy SIV

Daily Driver:


Verizon Samsung Galaxy SIV
ROM: Liquid Smooth 2.9
Kernel: Chronic

2GHz Quad Core!!