Or Continue to Thread: [Q] security warning with OTA …
Find Your Device:
31st August 2014, 03:39 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Aug 2014
More
Hi all, this is my first post here but I have been reading and searching here for a while.
After weeks of searching and trying different things nows its time to ask for help.

I have recently jumped from iPhones to HTC One M8. Every iPhone I had a Jailbroken and thought I would root my HTC so Ima bit new to all this.

Here's what I've done.

I have a Telstra branded HTC One M8.
After a week I decided to root it, after a lot of reading I Unlocked the Bootloader and installed TWRP, Did a backup straight away with TWRP and then I tried to S-off but firewater said it couldn't be done after 1 chug so I left it s-on.
That night I got the new OTA update so now I have to undo all I have done. I thought I would try the HTC one toolkit by Hasoon and followed the step by step instructions from TheUnlocker site ( can't post links yet)
I used Nandroid: CID TELST001 - 1.12.841.17 and Recovery 1.12.771.17.

All went smoothly and I was back to a stock phone, well AFAIK. I then downloaded and tried to install thew OTA update. Then phone reboots into the bootloader saying security warning under the tampered flag. I have tried unlocking the bootloader again and re-flashing the phone, I have even tried to s-on just in case when I tried to S-off it left something undone.

I'm now at my wits end so I'm asking for help.

Here's what I get when I try to return to S-on
...
(bootloader) [JAVACARD_ERR] SD/USBDISK Init error
(bootloader) writesecureflag: Permission denied, value 1
OKAY [ 0.002s]
finished. total time: 0.003s

D:\Android\toolkit\One_M8_All-In-One_Kit_v\data>

Also I got some error msgs when doing the bootloader (i think).
This is a copy from someone else but its the same error msg

(bootloader) [PGFS] partition_update_pgfs: pg1fs_security
(bootloader) Lock successfully...
(bootloader) deinit_lcd
(bootloader) mipi display off
(bootloader) mdp_clock_off
(bootloader) disable_mmss_clk done
(bootloader) pll1_disable done
(bootloader) TZ_HTC_SVC_DISABLE ret = -131073 (0xFFFDFFFF)
(bootloader) [CRITICAL] SPMI write command failure: cmd_id =
0, error
(bootloader) = 4
(bootloader) [CRITICAL] SPMI write command failure: cmd_id =
0, error
(bootloader) = 4
(bootloader) [INFO] Rebooting device
FAILED (status read failed (Too many links))
finished. total time: 1.170s

I hope someone can help out, I,m sick of the update screen popping up.

Thanks in advance.