Or Continue to Thread: [Q] Help! Stuck in HBOOT, can'…
Find Your Device:
1st September 2014, 12:20 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
29 posts
Join Date:Joined: Mar 2008
I've got a friend's HTC One M8 that's stuck in HBOOT. I can't flash a new recovery, I've tried both TWRP and CWM. Either time I get an error message "FAILED (remote: image update error)"

I'm at the end of my thread here with things I can try to fix it. I've searched almost all topics to no avail.

Here's the getvar dump:

C:\Users\Adrian>fastboot getvar all
(bootloader) version: 0.5
(bootloader) version-bootloader: 3.16.0.0000
(bootloader) version-baseband: N/A
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main:
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) imei2: Not Support
(bootloader) meid: 00000000000000
(bootloader) product: m8_ul_ca
(bootloader) platform: hTCBmsm8974
(bootloader) modelid: 0P6B12000
(bootloader) cidnum: CWS__001
(bootloader) battery-status: good
(bootloader) battery-voltage: 0mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: 0a41237a
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!

--

Device says *** UNLOCKED *** on screen, doesn't say TAMPERED (not sure what this is).

Anything fastboot commands usually result in a failed message but the device is recognized if I type "fastboot devices".

Here's a sample when trying to use Squabbi's toolkit:

target reported max download size of 1830727680 bytes
sending 'recovery' (24576 KB)...
OKAY [ 1.607s]
writing 'recovery'...
FAILED (remote: image update error)
finished. total time: 1.678s

I've tried using an ATT RUU, various recovery files, etc. The phone boots straight into HBOOT. Any other commands apart from fastboot on the device result in a quick flash of another screen and returns to the fastboot USB screen.

What can I do to get this device back up and running? For some reason I just can't get the recovery file to flash so I can move forward already. Am I missing something? I just got the device from a friend. He mentioned he was watching YT when all of a sudden the device went into this boot loop.

Thanks in advance!