Default Help needed for CDMA data service (downgrading from 4.4.2 to lower version)

I have a Samsung Galaxy S3 SCH-I535 CDMA Verizon & GSM phone. Originally it was on android 4.1.2 and working fine for both CDMA and GSM (one at a time). CDMA EVDO Rev A data service was working fine.

I am using this phone in Nepal (not in USA). It was carrier unlocked for both CDMA & GSM when I purchased from Amazon. (so, I guess, Originally it may had some customized firmware/ROM for International use, I don’t have much idea).

I was asked for firmware upgrade every time when I run Samsung Kies. One day I clicked to upgrade the firmware. The upgrade was over successfully. But the new android version I found on my phone was 4.4.2.
In this version /new upgrade, I was unable to use CDMA data (EVDO-rev A). So I wanted to reverse back to old version. I search the process in Google and tried to load firmware with the help of Odin3 using this file:- “I535VRBMF1_I535VZWBMF1_VZW.zip”, but it was not successful. Result: Fail(Auth)

Then I loaded firmware for 4.4.2 using Odin3.09 (AP: “I535VRUDNE1_I535VZWDNE1_I535VRUDNE1_HOME.tar.md5& rdquo and now the phone is working.
• If I use GSM SIM I can make call and use HSPA data service as well by adding new APN.
• If I use CDMA RUIM I can make call, BUT DATA SEVRICE using CDMA EVDO Rev A is NOT WORKING!! (I can not save APN in this case).

Now my issue is how to make CDMA EVDO data service working in my phone, because my basic requirement is to use this phone for CDMA service (voice + data).
I can edit the APN but when I click “Save”, nothing was saved. So I can not select APN for my carrier. I tried using APN Manager Pro too, here I can enter & enable the APN, but did not work. The phone is not able to dial the data access code #777 (verified from CDMA service provider side trace).

Can someone help me what I should do to make my phone working for CDMA data. My phone is rooted.
I guess it may work for CDMA data if I downgrade it to 4.3 or 4.1.2,
Can I do that. If so what are the procedures / steps. Any help in this regard would be highly appreciable.