Or Continue to Thread: [Recovery] [07-Jan-2011] RA-pa…
Find Your Device:
24th February 2010, 03:12 PM   |  #419  
landstander's Avatar
Senior Member
Flag KC metro area
Thanks Meter: 31
 
221 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by Alclub

Please help!!

I followed the instructions on this thread exactly:

I fastboot oem unlocked, got warning, accepted.

I flashed the 1.60 recovery image (checked md5), and the terminal on my pc said 'write ok'.

I rebooted into bootloader. (now says unlocked)
I chose the recovery option, but i still get the exclamation mark droid page (android system recovery 2e).

I've hard reset many times, but the recovery image wont overwrite the stock 2e recovery image!

Thanks in advanced! I wan't cyan soo bad!!

I had the same issue... I think the stock ROM (maybe just since the OTA update?) tries to "fix" the recovery image at startup, which results in you losing the just-flashed image. In any event, here's how I worked around it using recovery-RA-nexus v1.5.3:
  1. Copy each of the following to the root directory of your sdcard: update-cm-XXXXX-N1-signed.zip, and gapps-passion-ERE36B-2-signed.zip.
  2. Boot into recovery-RA without flashing (fastboot boot recovery-RA-nexus-vXXXXX.img). This will upload the recovery as a temporary boot image, so at this stage it needs to be present and accessible on your computer (not the sdcard).
  3. Wipe the device (Wipe data/factory reset)
  4. Flash the update-cm-XXXXX-N1-signed.zip file (Flash zip from sdcard). Do not reboot afterward.
  5. Flash the googly bits (gapps-passion-ERE36B-2-signed.zip) file.
  6. Reboot the device, and go through the normal Android account setup.

At this point you should be able flash the recovery successfully (and have it stick) via fastboot, using the normal procedure. If this still doesn't work, you also have the option of flashing it within CyanogenMod directly.
  1. Copy recovery-RA-nexus-vXXXXX.img to the root directory of your sdcard, and rename it to "recovery.img".
  2. Open the Terminal Emulater app, and type "su<ENTER>". Tap "Allow" when prompted for root access.
  3. Flash the image via "flash_image recovery /sdcard/recovery.img<ENTER>"

As usual with this rooting stuff, don't blame me if your N1 morphs into a rutabaga... I'm only reporting what I did, and don't promise that it's a risk-free proposition. Feel free to PM me if you have any questions, however.
Last edited by landstander; 24th February 2010 at 06:30 PM. Reason: consistent naming