As far as i know 2.1 does NOT have vulnarable recovery for this to work, so you will first need to replace recovery with vulnarable one, you have it all in first post.