Or Continue to Thread: [Program] Updated: 8-5-10: 1 C…
Find Your Device:
25th July 2010, 08:46 PM   |  #1157  
Junior Member
Thanks Meter: 1
 
18 posts
Join Date:Joined: Jul 2010
More
[Fixed] Step 4: starting part 2
Ok, I finally decided to take the plunge after reading about the CM6 ROM. Here's what I did and how I finally managed to get full root. I am pretty sure I figured out the Step 4: starting part 2 problem in the process. Not surprisingly, it's most likely user error.

Anyhow, I started by rooting using unrevoked3. Since this doesn't unlock NAND I was out of luck for CM6 nightlys. SimpleRoot was recommended so I found myself here. 4 hours later I was fully rooted.

1. Download and install .NET 4
2. Download and install latest Android SDK
3. Download and install HTC Sync
4. Download and unzip SimpleRoot
5. Since I had already semi-rooted I did a NAND backup at this point
6. Run OTA SimpleRoot.exe as admin
7. Connect phone via USB
8. select "Charge Only"
9. turn on USB Debbugging - Settings > Applications > Development > USB Debugging

I CAN'T STRESS THIS ENOUGH! READ EVERYTHING IN THE COMMAND PROMPT WINDOW AND FOLLOW THE INSTRUCTIONS EXACTLY!!!

10. Step 1 - per kennyc1:
Quote:

DO NOT CLOSE THE RED WINDOWS when you see "press any key to continue. READ THE INSTRUCTION!!

11. Step 2 - nothing special here, just be patient, it takes a couple minutes
12. Step 3 - This is the step that I screwed up repeatedly that causes the step 4 problem. Once you have loaded the page, the command prompt will update and say press any key EVEN IF YOU HAVE NOT RELOADED THE PAGE. RELOAD THE PAGE BEFORE YOU GO TO STEP 4!! THIS IS WHAT ALLOWS YOU TO DOWNGRADE!!
13. Step 4 - If you completed step 4 correctly then this should install the downgraded image. Your phone should see the file and automatically start the process. Press Volume Up to accept the update. Reboot in to your new rooted phone, start flashing your new ROM.

Step 4: step 2 starting problem
When I was having this problem I tried manually going in to recovery. PC36IMG.zip had not been pushed to the SD card so I put it there manually. I tried to flash manually and I got this
Quote:

Main Version is older!
Update Fail!
Do you want to reboot device?

I am pretty sure this is why step 2 stalls and never gets to the Androids skating screen. As soon as I re-ran step 3 correctly, step 4 worked perfectly.

Lastly, since I had unrevoked rooted I already had Clockwork recovery, but I could not get the phone in to recovery after SimpleRoot finished. I had to flash Clockwork using the SimpleRoot tool to get it to work.

A big thank you to jiqqaman for the killer app and kennyc1 and Jim M for posting their experience that finally got me to complete the process correctly.

I am now enjoying my CM6 Froyo sucker kick ass ROM.