5,597,937 Members 38,702 Now Online
XDA Developers Android and Mobile Development Forum

[K1] "Unsupported menu option selected" error & where to get TimmyDean rooted 13-13?

Tip us?
 
ssl123
Old
#1  
Senior Member - OP
Thanks Meter 49
Posts: 185
Join Date: Feb 2012
Default [K1] "Unsupported menu option selected" error & where to get TimmyDean rooted 13-13?

I just got a brand new K1. Fresh out of the box with 3-3 pre-installed, I downloaded and used TimmyDean's permanent root tool, flashing a rooted 2-2 firmware. I then enabled the backdoor and ran all the OTA updates up to 14-14. This took several hours in all. I then ran the BusyBox and SU Tools install script. Everything was looking okay. I selected the choice to exit the script with reboot. The K1 turned off and came back on with the Lenovo logo, but, at the top of the screen was red writing:

Unsupported menu option selected: 1
Unrecoverable bootloader error (0x00000002).

It stops there and goes no further. No bootup.

Attempting to research the error, it seems this is not an error too many people encounter or know about, so my guess is that my only way of fixing this problem is to flash the whole thing over again from the beginning. (Unless someone here knows something about this problem. That would be tremendously helpful.)

Having already experienced what it took to go from 2-2 to 14-14 the first time with the permanent root package, I'd certainly like to shortcut it however possible. In this thread, http://forum.xda-developers.com/show....php?t=1404351 , TimmyDean posted a rooted 13-13 that we can start from. However, the link to the download file for it is Multiupload.com, and Multiupload.com does not seem to be up for me. Does anyone know where else I can go to try and download a copy?

I'd have posted directly in that Development thread, but, since I am an XDA noob, the forum system only allows me to post in this General section.
 
ssl123
Old
(Last edited by ssl123; 20th February 2012 at 02:05 AM.)
#2  
Senior Member - OP
Thanks Meter 49
Posts: 185
Join Date: Feb 2012
After experimenting with the "permanent root" package several times now, each time ending up with the "Unsupported menu option selected: 1" error after any OTA update, I have to believe there is an incompatibility between the K1 I have and the bootloader files in the "permanent root" package. I do not know if my K1 is recently manufactured and they are now doing something different with them that causes this incompatibility or what, but I felt I should warn you all that flashing the "permanent root" package could cause your K1 to not take official updates or to otherwise brick it with the "unsupported menu option" error. Perhaps the 13-13 package, which I don't have and can't test, didn't have this problem.

My serial number is CB1245XXXX. Manufacture date is "11/11/27."

I have now given up on getting root on my K1 and would just be happy to get it back to a working condition that can take Lenovo's OTA updates without bricking. I am currently trying these instructions and will update as to whether or not that resolves the problem: rootzwiki.com/topic/13877-guide-ideapad-k1-restore-to-mostly-stock-with-ota-updates/ (The forum software will not allow me to post hot links, so copy and paste that to browser.)
 
ssl123
Old
#3  
Senior Member - OP
Thanks Meter 49
Posts: 185
Join Date: Feb 2012
The rootzwiki procedure did not work to correct the problem. After any update, the tablet is bricked with the error. There are a few threads on the Lenovo support forum on this issue now, and there is no solution.

forums.lenovo.com/t5/IdeaPad-Slate-Tablets/K1-not-booting-after-update/td-p/548285

forums.lenovo.com/t5/IdeaPad-Slate-Tablets/Unrecoverable-Boot-Loader-Error/td-p/683633

I believe these old bootloader files will not work and will brick newer K1's, so my warning is:

DO NOT ATTEMPT TO ROOT YOUR K1'S. DO NOT CHANGE THE EXISTING BOOTLOADER IN ANY WAY WITH NVFLASH. SOMETHING HAS CHANGED.

This might only apply to more recently manufactured K1's, but, since we do not know when this problem begins, it is not possible to know beforehand whether or not you will brick yours.

To be on the safe side, DO NOT ATTEMPT TO ROOT YOUR K1'S. DO NOT CHANGE THE EXISTING BOOTLOADER IN ANY WAY WITH NVFLASH. SOMETHING HAS CHANGED.

Unfortunately, there was no backup option in the rooting packages, so I could not get a copy of the stock bootloader or any other files, if they are indeed of a different and newer variety. If someone has a recently manufactured K1, perhaps you can get those files and share them, because a lot of people are starting to see this problem now.
 
traihan
Old
#4  
Member
Thanks Meter 0
Posts: 53
Join Date: Jan 2012
I have one with sn#1250xxxx, mfg dt 11/11/29. I wasn't even trying to root the thing. I happened during an OTA update. I tried probably all the recovery/rooting option out there. None of them worked. I have the tablet booting at lenovo screen. But I think you are right about the bootloader. If we can get the correct bootloader, we might be able to the the tablet back to life.
 
dms92969
Old
(Last edited by dms92969; 16th March 2012 at 04:57 PM.)
#5  
Junior Member
Thanks Meter 1
Posts: 14
Join Date: Mar 2012
Default fix?

Has anyone come out with the fix for your issue.. I have the same issue . Used TImmy Dean's method.. and anything updating past the 02_02 (loaded from the tool I get the error... Anyone here have access to contact JimmyDean to ask him for help?


I see that he updated the tool to K1_A301_13_13_111209_US and maybe K1_A301_14_14_111209_US but all the links are dead.. anyone have a good place to download the files?
 
rezapatel
Old
#6  
rezapatel's Avatar
Senior Member
Thanks Meter 303
Posts: 1,249
Join Date: Nov 2007
Try out the downloads on the following Lenovo's link -
download.lenovo.com/slates/k1/OTA
 
dms92969
Old
#7  
Junior Member
Thanks Meter 1
Posts: 14
Join Date: Mar 2012
those are just OTs.. not image files.. If you don't have a compatable boot loader, you can't load those files.. We don't have a compatable bootloader.. so this is why we need ver 13 of timmy dean..

Quote:
Originally Posted by rezapatel View Post
Try out the downloads on the following Lenovo's link -
download.lenovo.com/slates/k1/OTA
 
khanning88
Old
#8  
khanning88's Avatar
Member
Thanks Meter 263
Posts: 55
Join Date: Apr 2010
Location: USA

 
DONATE TO ME
Can someone who's getting this bootloader error send me a pm. I put together a stock 120109 update that may work around the issue and I need someone to test.
 
bludiamond
Old
#9  
bludiamond's Avatar
Member
Thanks Meter 2
Posts: 43
Join Date: Oct 2007
Location: Atlanta, GA
Was this issue ever resolved, I didnt attempt to root mine, only attempted to wipe it clean and got this..
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Android Control Center Becomes Quick Control Panel, Brings Host of New Features

You may recall that back in August of last year, we talked … more

Polish Your Custom Themes with Theme Debugger

Creating a custom Android theme from scratch can be quite the laborious task. In addition to … more

Clean Up Your Logcat Code with Lib Cleaner

Some of you may think that writing code is the hardest part of development. It’s not, as the … more

Tweak Your Xperia Device’s Camera App Yourself

We’ve come to expect nearly perfect cameraperformancein our modern day … more