Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

STRAIGHT TALK SIM APN SETTINGS (AT&T BASED, NOT T-Mobile)

OP deBricker

6th May 2012, 04:25 AM   |  #1  
deBricker's Avatar
OP Senior Member
Flag Naval Station Norfolk, VA
Thanks Meter: 153
 
342 posts
Join Date:Joined: May 2012
Donate to Me
More
I know this thread is old as hell, but to new users who are considering going with Straight Talk (ST), I suggest you do it. Its way cheaper than AT&T and you still get their coverage and not to mention unlimited data**. You can get the Straight Talk SIM card via their Bring Your Own Phone (BYOP) program. You can get it at their website.

**You get unlimited data as long as you don't abuse your data connection.

Oh and if you are having trouble trying to get data/mms working on your cappy with ST, here are the APN settings.

1. Download APN Back up/ restore from the Play Store

Name: ST (or whatever you want)
APN: att.mvno
Proxy: proxy.mvno.tracfone.com
Port: 80
Username: Not set
Password: Not set
Server: Not set
MMSC: http:// mmsc. cingular. com (no spaces)
MMSC proxy: 66.209.11.33
MMS port: 80
MCC: 310
MNC: 410
Authentication Type: Not set
APN type: default,supl,mms
APN protocol: IPv4
Bearer: Not specified

I use this with Froyo, Gingerbread, and ICS. It works perfectly!

Cheers and let me know if this helps you out.

UPDATE: 06302014
ST ATT 4G LTE APNs





Last edited by deBricker; 1st July 2014 at 04:27 AM. Reason: Update
The Following 9 Users Say Thank You to deBricker For This Useful Post: [ View ]
6th May 2012, 05:09 PM   |  #2  
903tex's Avatar
Senior Member
Flag Tyler, Texas
Thanks Meter: 201
 
977 posts
Join Date:Joined: Mar 2010
More
Stay under 2gb month 100mb a day and they will not call you! Get on Howard forums to straight talk sub forum to learn more about the BYOD Sims

Sent from my SGH-I897 using xda premium
The Following User Says Thank You to 903tex For This Useful Post: [ View ]
6th June 2012, 11:57 PM   |  #3  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Apr 2012
Angry Re:ST
I just got a Samsung sch-i727 put in ST sim and reloaded it since I had let it expire. Set apn up and I am now getting hspa+ expanded 4g signal. Fastest speed so far is 3.5mb. I highly recommend.
30th August 2013, 06:02 AM   |  #4  
Member
Thanks Meter: 4
 
32 posts
Join Date:Joined: Mar 2012
Not working
Quote:
Originally Posted by h60cruchief

I just got a Samsung sch-i727 put in ST sim and reloaded it since I had let it expire. Set apn up and I am now getting hspa+ expanded 4g signal. Fastest speed so far is 3.5mb. I highly recommend.


What apn settings do you have I tried many and still not working
30th August 2013, 06:26 AM   |  #5  
BWolf56's Avatar
Recognized Contributor
Flag Outaouais
Thanks Meter: 1,706
 
3,891 posts
Join Date:Joined: Mar 2011
Donate to Me
More
Quote:
Originally Posted by twinels

What apn settings do you have I tried many and still not working

The ones in the OP.
The Following 2 Users Say Thank You to BWolf56 For This Useful Post: [ View ]
30th August 2013, 07:19 PM   |  #6  
Member
Thanks Meter: 4
 
32 posts
Join Date:Joined: Mar 2012
Found what works for my AT&T I717 ST APN
Quote:
Originally Posted by BWolf56

The ones in the OP.


name:ST
APN:tfdatta
Proxyroxy.mvno.com
Port:80
MMSC:http://mms-tf.net
MMS port:80
MCC:310
MNC:410
Everything else left not set
I was told to turn off data roaming but it works with it on
The Following User Says Thank You to twinels For This Useful Post: [ View ]
30th August 2013, 08:30 PM   |  #7  
m1batt1's Avatar
Senior Member
Flag Springfield, MO
Thanks Meter: 436
 
718 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by twinels


name:ST
APN:tfdatta
Proxyroxy.mvno.com
Port:80
MMSC:http://mms-tf.net
MMS port:80
MCC:310
MNC:410
Everything else left not set
I was told to turn off data roaming but it works with it on

Depending on when you got the sim card from straight talk the above might not work. They have changed their APN settings recently and if you're like me and have the older sim this new setup doesn't work. If you do a bit of googling you'll find the old settings out there too. Though I believe they are somewhere in this thread.

Sent from my SGH-I927 using xda app-developers app
The Following User Says Thank You to m1batt1 For This Useful Post: [ View ]
11th June 2012, 09:23 PM   |  #8  
Senior Member
Thanks Meter: 28
 
363 posts
Join Date:Joined: Jul 2008
so I've got the n9000 Note.. and under APN type I don't have the option for default,supl,mms... just internet+mms, Internet and MMS. ?
21st June 2012, 06:48 AM   |  #9  
deBricker's Avatar
OP Senior Member
Flag Naval Station Norfolk, VA
Thanks Meter: 153
 
342 posts
Join Date:Joined: May 2012
Donate to Me
More
Quote:
Originally Posted by tri0xinn

so I've got the n9000 Note.. and under APN type I don't have the option for default,supl,mms... just internet+mms, Internet and MMS. ?

Yes. That is correct

Sent from my Galaxy Nexus using XDA
22nd June 2012, 05:00 AM   |  #10  
wwcjr91's Avatar
Senior Member
Flag Northern Wisconsin
Thanks Meter: 80
 
214 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by deBricker

: Not set
MMSC: http: mmsc. cingular. com [/B](**no spaces and no"//"**)[B]
MMSC proxy: 66.209.11.33
MMS port: 80
MCC: 310
MNC: 410
Authentication Type: Not set
APN type: default,supl,mms
elps you out.

Why no slashes? That's what ST recommended and I haven't had problems yet with my captivate. Thanks for the thread.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes