FORUMS

New Xposed for Lollipop 5.0 Update Fixes Major Bugs

Senior Recognized Developer rovo89 has patched Xposed for Lollipop 5.0 to … more

Download Sony’s new AOSP-like concept for Xperia Z3

Over in our forums, Recognized Contributor Jozinek has posted a very … more

OnePlus 2 vs Moto X Style: Which is The Better Flagship?

Two big industry names have announced their newest flagship phones within the … more

Making Your Own Xposed Modules Is Easier Than You Think

Close to the heart of XDA is the Xposed Framework by Rovo89. Most of … more
Post Reply Subscribe to Thread Email Thread
So I gave this a shot and it worked perfectly.

1. Root your Kindle Fire HD
2. Downloaded and install the GoogleServicesFramework.apk
3. Download Vending.apk
4. Using a file explorer app on the Fire with superuser permissions AND the system file permissions set to Read-Write, move Vending.apk to /system/app.
5. Change the permissions of Vending.apk to User - Read/Write, Group - Read, Others - Read
6. Install Vending.apk
7. The Android Market should show up in your Kindle Fire HD apps. Tap on it and follow the steps.
8. Download and install the Play.apk to upgrade the the android market to the current Play market.
9. Enjoy!

GoogleServicesFramework.apk - mediafire.com/?zaumfwhraxcifqf
Vending.apk - mediafire.com/?31bn3e258jjpj8d
Play.apk - mediafire.com/?wwcqrlfwt8o1gnv
Last edited by stopxwatch; 18th September 2012 at 07:43 PM. Reason: added content
The Following 46 Users Say Thank You to stopxwatch For This Useful Post: [ View ]
18th September 2012, 07:25 PM |#2  
adiliyo's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 238
 
More
how about attaching said apks?

or at least which ones?

i'm going to guess it's the latest gapps for ICS though?
18th September 2012, 07:36 PM |#3  
OP Junior Member
Thanks Meter: 48
 
More
Quote:
Originally Posted by adiliyo

how about attaching said apks?

or at least which ones?

i'm going to guess it's the latest gapps for ICS though?

GoogleServicesFramework.apk - mediafire.com/?zaumfwhraxcifqf
Vending.apk - mediafire.com/?31bn3e258jjpj8d
Play.apk - mediafire.com/?wwcqrlfwt8o1gnv
The Following User Says Thank You to stopxwatch For This Useful Post: [ View ]
18th September 2012, 07:29 PM |#4  
Senior Member
Thanks Meter: 10
 
More
less then a week and its already been rooted and got the play store damn.

Sent from my SCH-I535 using Tapatalk 2
18th September 2012, 07:36 PM |#5  
reverendkjr's Avatar
Senior Member
Flag Cincinnati, OH
Thanks Meter: 849
 
More
Quote:
Originally Posted by stopxwatch

So I gave this a shot and it worked perfectly.

1. Root your Kindle Fire HD
2. Downloaded and install the GoogleServicesFramework.apk
3. Download Vending.apk
4. Using a file explorer app on the Fire with superuser permissions AND the system file permissions set to Read-Write, move Vending.apk to /system/app.
5. Change the permissions of Vending.apk to User - Read/Write, Group - Read, Others - Read
6. Install Vending.apk
7. The Android Market should show up in your Kindle Fire HD apps. Tap on it and follow the steps.
8. Download and install the Play.apk to upgrade the the android market to the current Play market.
9. Enjoy!

Keep in mind that we have no way of restoring the system folder yet, so if anything goes wrong with this process, you may end up bricking your tablet. Just a warning.
The Following 2 Users Say Thank You to reverendkjr For This Useful Post: [ View ]
27th October 2012, 01:28 PM |#6  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by reverendkjr

Keep in mind that we have no way of restoring the system folder yet, so if anything goes wrong with this process, you may end up bricking your tablet. Just a warning.

should have paid more attention to that *facepalm*

in step 4 what should I set to read/write? user, group, what?
28th October 2012, 10:51 AM |#7  
Junior Member
Thanks Meter: 0
 
More
After upgraded to 7.2.1, I couldn't get Google map to work. I have in it put in system/app folder, changed permission. But it just won't install...
18th September 2012, 07:36 PM |#8  
adiliyo's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 238
 
More
so, i'm getting application not installed errors when trying to do this.
18th September 2012, 09:11 PM |#9  
Member
Thanks Meter: 2
 
More
can you install different launcher now?

Sent from my SPH-D710 using Tapatalk 2
18th September 2012, 09:41 PM |#10  
adiliyo's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 238
 
More
has anyone got this to work completely? i got the market to install along with the framework services, but i can't log into my account, it tries and then times out after a while.

am i missing something?
The Following User Says Thank You to adiliyo For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes