5,603,729 Members 37,862 Now Online
XDA Developers Android and Mobile Development Forum

[Guide] Use your tablet/phone as PC for Fastboot and ADB

Tip us?
chamatht's Avatar
Senior Member - OP
Thanks Meter 459
Posts: 425
Join Date: Nov 2011
Location: Colombo
Sign [Guide] Use your tablet/phone as PC for Fastboot and ADB

In this guide i will show you how to use tablet/phone as a computer for adb and fastboot purposes.

With android devices most of people here in xda can't stay away from using Fastboot or adb. I'm changing kernel of my xperia neo frequently. Unlike samsung, in sony, kernels cannot be flashed without fastboot. So I'm using adb and fastboot frequently,
But what happens if u don't own a PC, or of ur PC is not working.
This guide is helpful for people who doesn't have a PC, who are too lazy to turn on their pc , who are outside from the house, etc.

Okay.. Enough talk. Let's get into work.

Requirements :-
* Rooted android Tablet / Phone.
* OTG cable [ Make sure that your device supports OTG. (If not search your device's thread for OTG )]
* A root browser ( eg:- Root Explorer, ES file explorer)
* Terminal emulator

( um not responsible for your bricked device.)

You may think that we can use adb and fastboot binary files for linux in our android devices. No. We can't use them. Because those files are not compiled for ARM. So we can't use them.

Thanks to google we have adb compiled for ARM. This file is already included in some new devices. ( search "adb" in /system/bin or /system/xbin folder. If you have this you don't need to download this again)
Thanks to josteink we have Fastboot binary compiled for ARM. This isn't coming with your device natively.

1. Download adb file here
2. Download fastboot file here

* Copy those two files to /system/bin to folder.

* set permissions manually if you know how to do it.

If not open terminal emulator. Then enter following,
mount -o remount,rw /system
chmod 755 /system/bin/fastboot
chmod 755 /system/bin/adb
*Reboot your device.

Now you're done.

*Open terminal emulator and type
If you see some text like this, Fastboot is working.
u0_a60@grouper:/ $ fastboot
usage: fastboot [ <option> ] <command>

  update <filename>                        reflash device from update.zip
  flashall                                 flash boot + recovery + system
  flash <partition> [ <filename> ]         write a file to a flash partition
  erase <partition>                        erase a flash partition
  getvar <variable>                        display a bootloader variable
  boot <kernel> [ <ramdisk> ]              download and boot kernel
  flash:raw boot <kernel> [ <ramdisk> ]    create bootimage and flash it
  devices                                  list all connected devices
  continue                                 continue with autoboot
  reboot                                   reboot device normally
  reboot-bootloader                        reboot device into bootloader
  help                                     show this help message

  -w                                       erase userdata and cache
  -s <serial number>                       specify device serial number
  -p <product>                             specify product name
  -c <cmdline>                             override kernel commandline
  -i <vendor id>                           specify a custom USB vendor id
  -b <base_addr>                           specify a custom kernel base address
  -n <page size>                           specify the nand page size. default: 2048
adb version
If you see some text like this, adb is working.
u0_a60@grouper:/ $ adb version
Android Debug Bridge version 1.0.31
Tada... You have adb and fastboot in your tablet/phone.

*connect another android device to your device by otg cable. And try out adb and fastboot.
*(use "su" command before using fastboot and adb in terminal. Otherwise fastboot/adb will not function well)

*Report here if adb and fastboot working in your device

Last important STEP
*press thanks button.

Current Devices : SE Xperia Neo V , Google Nexus 7

Previous Devices : Huawei U8160, Samsung Galaxy Y, Samsung Galaxy Ace, Samsung Galaxy S

My Works
[Guide] Use your tablet/phone as PC for Fastboot and ADB

Samsung Galaxy Y :
How to Deodex stock Rom
Kernel Backup - to backup kernel
ICS Settings app for stock and custom roms
Touchwiz Launcher with landscape orientation

The Following 4 Users Say Thank You to chamatht For This Useful Post: [ Click to Expand ]
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Nov 2013
Thumbs up adb/fastboot

Succesfully installed adb/fastboot in galaxy tab3
abshire57's Avatar
Junior Member
Thanks Meter 1
Posts: 14
Join Date: Jul 2010
Location: San Pedro
Works on Nexus5 with Samsung otg cable
MistaJae's Avatar
Senior Member
Thanks Meter 36
Posts: 237
Join Date: May 2010
I tried to use fastboot on my 2012 Nexus 7 via my Nexus 5. When I type 'adb devices' my Nexus7 shows up, but it says 'unauthorized'.

Any ideas?
BTW, both devices are running 4.4.2
Phone(s): HTC One M8
ROM(s): Stock
Kernel(s): Stock
Network(s): T-Mobile UK (EE)
(Last edited by p70shooter; 21st March 2014 at 10:25 PM.)
p70shooter's Avatar
Senior Member
Thanks Meter 167
Posts: 413
Join Date: Jan 2013
Thanks for this guide. Got fastboot working no probs but want to flash a Kernel on my One X but don't know where to put the boot.img? On my pc I put it in the fastboot folder but where does it go on my nexus? I'm sure I'm being thick but I'm confused

---------- Post added at 11:23 PM ---------- Previous post was at 11:19 PM ----------

Originally Posted by MistaJae View Post
I tried to use fastboot on my 2012 Nexus 7 via my Nexus 5. When I type 'adb devices' my Nexus7 shows up, but it says 'unauthorized'.

Any ideas?
BTW, both devices are running 4.4.2
Probably a really stupid question but did you try it in recovery? Works for me.
I'm not sorry for my crap english, I'm Cornish.
adb, fastboot, use adb in tablet, use fastboot in tablet, use phone to fastboot
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes