5,600,292 Members 35,926 Now Online
XDA Developers Android and Mobile Development Forum

[Q&A] Missing Play Store or others after Flashing ROM and Gapps

Tip us?
 
Asparagus13
Old
(Last edited by Asparagus13; 3rd January 2014 at 01:08 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
Sign [Q&A] Missing Play Store or others after Flashing ROM and Gapps

Mainly caused by not properly following the steps below

1. Boot into CwM or TWRP recovery.
Wipe cache, dalvik cache and data.
2. Flash rom.zip. and Reboot.
Allow tab up to 20 minutes (usually takes much less time) to reboot to the initial Setup screen.
Complete the initial setup (CM Account setup is optional).

3. Go to Settings, and enable Developer Options, allow installation from Unknown Sources,
enable Android Debugging, enable Advanced Reboot, etc. and then Reboot.

4. install GApps.

My experience is that the most important parts are

A. wipe cache, wipe dalvik cache and wipe data, if you are not sure, you can do this every time before flashing any .zip and before booting. It won't hurt to wipe it many times.

B. make sure completed configuring all the setting on step 3, including "allow installation from Unknown Sources", before install GApps.

If you believe any step is not right or not necessary, please let me know.
 
Tyrador79
Old
(Last edited by Tyrador79; 7th January 2014 at 07:52 AM.) Reason: mistyping
#2  
Junior Member
Thanks Meter 0
Posts: 8
Join Date: Jan 2011
Quote:
Originally Posted by Asparagus13 View Post
Mainly caused by not properly following the steps below

1. Boot into CwM or TWRP recovery.
Wipe cache, dalvik cache and data.
2. Flash rom.zip. and Reboot.
Allow tab up to 20 minutes (usually takes much less time) to reboot to the initial Setup screen.
Complete the initial setup (CM Account setup is optional).

3. Go to Settings, and enable Developer Options, allow installation from Unknown Sources,
enable Android Debugging, enable Advanced Reboot, etc. and then Reboot.

4. install GApps.

My experience is that the most important parts are

A. wipe cache, wipe dalvik cache and wipe data, if you are not sure, you can do this every time before flashing any .zip and before booting. It won't hurt to wipe it many times.

B. make sure completed configuring all the setting on step 3, including "allow installation from Unknown Sources", before install GApps.

If you believe any step is not right or not necessary, please let me know.
Since a while i wipe cache and dalvik cache again after installing GApps in step 4 and till now it works perfectly.

PS: i dont wipe data every time in step 1, execpt it is a major Rom update
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes