Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,065 Members 40,715 Now Online
XDA Developers Android and Mobile Development Forum

Need advice on mess with S3 update ....

Tip us?
 
vax1170
Old
(Last edited by vax1170; 12th January 2014 at 04:11 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 23
Join Date: Feb 2011
Default Need advice on mess with S3 update ....

Hello all,
Short story, wife had the 4.3 OTA nag popup, accidentally hit 'ok' and pulled battery before unit booted.

I thought maybe I could avoid the 4.3 OTA by flashing CWM via heimdall. I followed the CM directions for d2vzw at wiki.cyanogenmod.org/w/Install_CM_for_d2vzw, basically I did the following:

heimdall flash --ABOOT aboot.mbn --no-reboot
heimdall flash --BOOT boot.img --no-reboot
heimdall flash --RECOVERY recovery-clockwork-6.0.4.5-d2vzw.img

However when I try to boot into recovery mode, I get the android character with spinning globe. I only saw the picture long enough to pull the battery.

Any suggestions on this on? It looks like the confirmation for OTA sets something, and it appears that whatever I did above either was wrong, didn't happen properly, or is ignored at this point. If I boot back into download mode I still see custom binary no, and current/system binary official.

I would like to get this to CWM and CM 10.2, but suspect it is too late ... can anyone tell me how to work around this, or should I just bite the bullet and reboot to see if the OTA updates at this point?

Thanks for any help you can advise on ....
 
buhohitr
Old
#2  
buhohitr's Avatar
Senior Member
Thanks Meter 1499
Posts: 5,127
Join Date: Nov 2011
Quote:
Originally Posted by vax1170 View Post
Hello all,
Short story, wife had the 4.3 OTA nag popup, accidentally hit 'ok' and pulled battery before unit booted.

I thought maybe I could avoid the 4.3 OTA by flashing CWM via heimdall. I followed the CM directions for d2vzw at wiki.cyanogenmod.org/w/Install_CM_for_d2vzw, basically I did the following:

heimdall flash --ABOOT aboot.mbn --no-reboot
heimdall flash --BOOT boot.img --no-reboot
heimdall flash --RECOVERY recovery-clockwork-6.0.4.5-d2vzw.img

However when I try to boot into recovery mode, I get the android character with spinning globe. I only saw the picture long enough to pull the battery.

Any suggestions on this on? It looks like the confirmation for OTA sets something, and it appears that whatever I did above either was wrong, didn't happen properly, or is ignored at this point. If I boot back into download mode I still see custom binary no, and current/system binary official.

I would like to get this to CWM and CM 10.2, but suspect it is too late ... can anyone tell me how to work around this, or should I just bite the bullet and reboot to see if the OTA updates at this point?

Thanks for any help you can advise on ....
Boot into download mode (vol down + Home + power button). Do you see this? If you see the last 2 lines you are on 4.3
product name: sch-i535
custom binary download: no
current binary Samsung: official
QUALCOMM secureboot: enable
warranty bit:0
bootloader rp swrev: 1
secure check fail: recovery
The Following User Says Thank You to buhohitr For This Useful Post: [ Click to Expand ]
 
vax1170
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 23
Join Date: Feb 2011
Quote:
Originally Posted by buhohitr View Post
Boot into download mode (vol down + Home + power button). Do you see this? If you see the last 2 lines you are on 4.3
product name: sch-i535
custom binary download: no
current binary Samsung: official
QUALCOMM secureboot: enable
warranty bit:0
bootloader rp swrev: 1
secure check fail: recovery
No not quite. I don't see the last few lines. My eyes are a bit old but what I see is only:
ODIN MODE
product name: SCH-I535
custom binary download: no
current binary: Samsung official
System status: Official
QUALCOMM secureboot ENABLE

And nothing else after that (just the green antroid graphic and 'downlaoding....')

Thank you for the fast response
 
buhohitr
Old
#4  
buhohitr's Avatar
Senior Member
Thanks Meter 1499
Posts: 5,127
Join Date: Nov 2011
Quote:
Originally Posted by vax1170 View Post
No not quite. I don't see the last few lines. My eyes are a bit old but what I see is only:
ODIN MODE
product name: SCH-I535
custom binary download: no
current binary: Samsung official
System status: Official
QUALCOMM secureboot ENABLE

And nothing else after that (just the green antroid graphic and 'downlaoding....')

Thank you for the fast response
Seems like the 4.3 didn't make it. You can boot up the phone and re check..Once phone is up just turn off wifi and 4g to prevent the OTA.
The Following User Says Thank You to buhohitr For This Useful Post: [ Click to Expand ]
 
vax1170
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 23
Join Date: Feb 2011
Quote:
Originally Posted by buhohitr View Post
Seems like the 4.3 didn't make it. You can boot up the phone and re check..Once phone is up just turn off wifi and 4g to prevent the OTA.
Sorry I wasn't clear ....
I believe the phone already had the OTA software downloaded and staged for install. It was popping up that nag screen that asks to run the update. My wife pressed 'OK' on that and as the phone shutdown and brought up the 'samsung' splash screen, the battery was pulled.

It was after this that I attempted to follow the CM directions to flash the older bootloader and CWM. However I don't think it was successful.

After running the procedure, I attempt to boot into recovery. I am expecting to see the usual CWM menu, however I don't. I get the android with the spinning globe in the belly. I am thinking, the flash with CWM didn't take, and the OTA is now attempting to install.

If possible I would like to flash CWM and then load up CM 10.2 from an internal SD card I've prepared.

Let me know what you think .... thanks!
 
buhohitr
Old
#6  
buhohitr's Avatar
Senior Member
Thanks Meter 1499
Posts: 5,127
Join Date: Nov 2011
Quote:
Originally Posted by vax1170 View Post
Sorry I wasn't clear ....
I believe the phone already had the OTA software downloaded and staged for install. It was popping up that nag screen that asks to run the update. My wife pressed 'OK' on that and as the phone shutdown and brought up the 'samsung' splash screen, the battery was pulled.

It was after this that I attempted to follow the CM directions to flash the older bootloader and CWM. However I don't think it was successful.

After running the procedure, I attempt to boot into recovery. I am expecting to see the usual CWM menu, however I don't. I get the android with the spinning globe in the belly. I am thinking, the flash with CWM didn't take, and the OTA is now attempting to install.

If possible I would like to flash CWM and then load up CM 10.2 from an internal SD card I've prepared.

Let me know what you think .... thanks!
It's possible that the 4.3 bootloader already flashed and it's in the process of flashing the rom when you pulled the battery. In any case, if the software is half done you phone won't boot, and if you attempt to flash the old rom, you will brick your phone if the bootloader already locked. So you need to turn it on to see where you at or you can take a chance and try to Odin old stock rom, again if the bootloader already locked you will brick your phone and if not then you will be back to the older version. I would turn it on and see.
The Following User Says Thank You to buhohitr For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes