Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,106 Members 41,799 Now Online
XDA Developers Android and Mobile Development Forum

Xperia ZL problem with flashmode

Tip us?
 
Karakatoa
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Sep 2012
Exclamation Xperia ZL problem with flashmode

Hi guys.
My problem is that I tried to install cm11 on my xperia so I rooted it, then I unlocked the bootloader and then I installed CWM.
So I started with the wiping, and though im quite used to the procedure I made the mistake of wiping data, cache and... system :/, Ive done it before but this time the cm11 zip failed to install and though I tried, it kept telling me there was an error with some changes and it aborted.
Was kind of busy so turned it off, big mistake, as I expected, when I tried to turn it on it started the bootloop.
So here I am with its battery fully discharged and no OS on the device.
But my fear is that now it only goes into fastboot, but when I try to set it on flashmode the led quickly flashes green, then red and then none, and it doesnt go into flashmode. So im out of ideas as to how can I recover it.
Do you think it is bricked? Is there a way to get it working again?
I thought about getting it to sony, but I dont know how they'd react to my flashing mistakes xD Wanted to ask you guys first.
Thanks in advance to anyone. And pleasee tell me theres a way around this xDD
x102x96x Old
#2  
Guest
Thanks Meter 0
Posts: n/a
Quote:
Originally Posted by Karakatoa View Post
Hi guys.
My problem is that I tried to install cm11 on my xperia so I rooted it, then I unlocked the bootloader and then I installed CWM.
So I started with the wiping, and though im quite used to the procedure I made the mistake of wiping data, cache and... system :/, Ive done it before but this time the cm11 zip failed to install and though I tried, it kept telling me there was an error with some changes and it aborted.
Was kind of busy so turned it off, big mistake, as I expected, when I tried to turn it on it started the bootloop.
So here I am with its battery fully discharged and no OS on the device.
But my fear is that now it only goes into fastboot, but when I try to set it on flashmode the led quickly flashes green, then red and then none, and it doesnt go into flashmode. So im out of ideas as to how can I recover it.
Do you think it is bricked? Is there a way to get it working again?
I thought about getting it to sony, but I dont know how they'd react to my flashing mistakes xD Wanted to ask you guys first.
Thanks in advance to anyone. And pleasee tell me theres a way around this xDD
u don't have recovery!?
before try to flash rom
try to install recovery first and then through recovery try to flash.
if u side-loaded rom in internal memory and aborted error appear try to install it from usb-otg.

 
Karakatoa
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Sep 2012
Quote:
Originally Posted by x102x96x View Post
u don't have recovery!?
before try to flash rom
try to install recovery first and then through recovery try to flash.
if u side-loaded rom in internal memory and aborted error appear try to install it from usb-otg.


The things I wiped data and system partitions, the zip is still in the internal memory but I have no access to it.
Im trying to say I cant even try to turn it on or enter recovery without it going into bootloop.
Can you tell me more about that otg-usb? What do you mean?
It wont even get into flashmode.
x102x96x Old
#4  
Guest
Thanks Meter 0
Posts: n/a
Quote:
Originally Posted by Karakatoa View Post
The things I wiped data and system partitions, the zip is still in the internal memory but I have no access to it.
Im trying to say I cant even try to turn it on or enter recovery without it going into bootloop.
Can you tell me more about that otg-usb? What do you mean?
It wont even get into flashmode.
fastboot is enough to install recovery.
follow this;
Installing recovery using fastboot

-
after installing recovery cwm or twrp (that u can find them in dev section)
it s time to install rom (flashing rom)
then u should boot into recovery. almost of recoveries have built-in file-manager it means u will access to ur file in internal memory.
if u cannot install rom from internal memory then connect usb by otg cable.
it means transfer flashable rom.zip to USB-flash memory and then connect it to ur phone and install ROM from it.

hope to have success
 
bhavstech
Old
#5  
bhavstech's Avatar
Senior Member
Thanks Meter 224
Posts: 785
Join Date: Aug 2013
Quote:
Originally Posted by Karakatoa View Post
Hi guys.
My problem is that I tried to install cm11 on my xperia so I rooted it, then I unlocked the bootloader and then I installed CWM.
So I started with the wiping, and though im quite used to the procedure I made the mistake of wiping data, cache and... system :/, Ive done it before but this time the cm11 zip failed to install and though I tried, it kept telling me there was an error with some changes and it aborted.
Was kind of busy so turned it off, big mistake, as I expected, when I tried to turn it on it started the bootloop.
So here I am with its battery fully discharged and no OS on the device.
But my fear is that now it only goes into fastboot, but when I try to set it on flashmode the led quickly flashes green, then red and then none, and it doesnt go into flashmode. So im out of ideas as to how can I recover it.
Do you think it is bricked? Is there a way to get it working again?
I thought about getting it to sony, but I dont know how they'd react to my flashing mistakes xD Wanted to ask you guys first.
Thanks in advance to anyone. And pleasee tell me theres a way around this xDD
did u flash the kernel of cm11 by flash tool b4 installing the rom if no do it first and then install the rom
If i helped you ,you know where the Thanks button is!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes